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Enhancements for MIMIC

Introduction
MIMIC is a user-friendly research software program for creating graphs and tables of historical data.

This document illustrates the enhancements made to the MIMIC software for the latest releases. For details
on bug fixes and a complete list of all changes, please see the  MIMIC Release Notes. For instructions on using
the MIMIC software, see the tutorial  MIMIC Training Guide  and the  MIMIC User Guide.

Release 4.1.0
Please see the  MIMIC Release Notes  for information on bug fixes and minor software enhancements.

Stepped Curves
When stepped curves are turned off, the contract price will be placed on the first business day of the delivery
month which will represent a forward curve. If the stepped curves check box is selected, a value is placed on
every day of the delivery month. The default setting is that stepped curves are turn off. Navigate to the User
Preferences dialog box (Options > User Preferences) to control the stepped curves option.

http://customers.lim.com/pdfdocs/mimic_release_notes.pdf
http://customers.lim.com/pdfdocs/mimic_training_4.pdf
http://customers.lim.com/pdfdocs/mimic_user_4.pdf
http://customers.lim.com/pdfdocs/mimic_release_notes.pdf
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The following shows the User Preferences dialog box:

The following shows a chart when stepped curves are turned off:
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The following shows the same chart when stepped curves are turned on:

Formula Warning Message
When deleting rows that affect formulas, the following warning message is displayed. If you do not want the
warning message repeated during the current session, select the check box.

Release 4.0.1
The following shows the enhancements for the 4.0.1 release of MIMIC.
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Charting
There are several charting enhancements in this release. Here's a synopsis of the changes:

1. Control the Y-axis in a chart
2. Add text notes to a chart
3. Define the line thickness in a chart
4. Specify the symbols to use in a chart
5. Use the arrow keys to move the Mouse Pick lines in a chart
6. In the Worksheet, right-click in the Chart Type column and make all the items the same chart type.

Control Chart Y-axis

The user has control of the chart Y-axis. To change the Y-axis, select the Axis Config  button in
the Worksheet Options pane. Select the Scale tab and change the mode from Automatic to Manual. In the
Min field enter the amount you would like to scale the Y-axis.

Chart Notes

You can now add text notes to a chart. To create a note, right click in a chart and select Add Note. Type your
note information and select OK. You can click on the note and reposition the note anywhere on the chart. To
edit a note, double-click on the note (or right click and select Edit Note). You can now edit the note text. To
delete a note, right click the note and select Delete Note or select the note and click the Delete key.

Chart Line Thickness and Symbol

From the Options menu select Chart Configuration. In the Chart Configuration window you can now
define the line thickness and symbol for each data series on the chart.
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Positioning Mouse Pick Lines

For greater control, move the Mouse Pick lines using the arrow keys on your keyboard.

To access the Mouse Pick feature select View>Chart Options>Controls from the menu bar to turn on the
controls at the bottom of a chart. Next, execute a chart, then turn on the Mouse Pick feature by selecting the
Mouse Pick Off button (will display as Mouse Pick On when activated). You can move the Mouse Pick
lines with your mouse or use the arrow keys to move the lines one pixel at a time.
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Unify the Chart Type
You can unify the Chart Types. For example, let's unify the following Chart Type to LINE. To do this, select
in the Chart Type field for the symbol CL, then right click and select Set All Chart Types to Line.

All the Chart Types are set to LINE:
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Connection Manager
The Connection Manager is used to make connections to your servers. You will need to enter the host, port
number and description for each connection. You may define multiple connections. This allows for easy
switching between servers. To access the Connection Manager, select Options>Connection Manager from
the menu bar.

To establish a new connection, select the New  button and define the connection in the New Connection
dialog box. Select the OK  button to use this connection. To edit a connection, select the Edit  button.
To delete a connection, select the Delete  button.

A restart of the application is not necessary when changing server connections.

Favorites
In the Search Database window select multiple symbols in the Tree View tab and drag them to the Add to
Favorites  button to add them to the Favorites list. You can add multiple symbols by using the Shift and
Ctrl keys on your keyboard.

Select the symbol(s) to highlight the symbol selection(s) then click on the highlighted group or
single symbol and drag to the Favorites  button.
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Tree View Refresh
You can now refresh the Tree View listings in the Search Database window. The Refresh  button is
located in the bottom right corner of the Tree View window.

Table Results

More than a 100 Results
When you execute a Table  and there are more than 100 results then the results may be limited by the
server. There is now a message on the Table: "Found 100 Results".

The results may be limited to 100 by the server.

Show Dates as Columns
In the Table Options pane, check the check box for Show Dates As Columns and select the Execute
Table  button. The table results are landscaped and are formatted so that the columns="dates for the
values" and the rows="values for a relation".

Usually the columns="values for a relation" and the rows="dates for the values".

Releases 3.2.0.2 - 3.2.0.4
These releases contain bug fixes. For details, see the MIMIC Release Notes.

Release 3.2.0.1
Added LmpVal to the list of preferred columns. This allows LmpVal to be the default column if no other
preferred column is found.

http://customers.lim.com/pdfdocs/mimic_release_notes.pdf
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Release 3.2.0.0

Online Help & Context-Sensitive Help
MIMIC now offers online Help with a context-sensitive component. Within the online Help, you can find a
topic using the Search feature or the Index feature. If you think you may want to access a topic again, you
can add it to your favorites and easily access it again in the future through the Favorites menu. The MIMIC
Online Help offers topics for both the MIMIC User Guide and the MIMIC Training Guide. Each top level of
these guides contains a table of contents with hyperlinks, which you can use to navigate directly to a topic.

You can access the online Help by selecting Help>MIMIC Help from the menu bar.

The context-sensitive Help component allows you to find a Help topic for a specific area on the interface you
select. You can access the context-sensitive Help by selecting the Context-Sensitive Help  button from
the MIMIC toolbar:

When you click on the Context-Sensitive Help  button, your cursor changes to a question mark. Then,
you can click in the Configuration window where you have a particular question, and the MIMIC Help
will open with information on that question. Context-sensitive Help is also available in secondary windows,
including the User Preferences window (Options>User Preferences), and the Seasonal Analysis
Configuration window.

Interface Updates and Navigation Improvements

Interface Updates
MIMIC now includes an improved and enlarged MIMIC toolbar and an updated Worksheet toolbar:
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The Worksheet toolbar contains a new button called the Insert Row  button. You can select this button
to insert a row above your currently selected row. Note also the addition of the Context-Sensitive Help 
button.

Other changes to the MIMIC interface include a new Search Database  button:

There is also a new look to the Edit Chart Stats  button, and beside Custom
Contract, the Edit Policy button changed to the Edit Rollover  button.

Finally, in the Worksheet Options pane next to Seasonal Analysis, the Seasonal Analysis  button

replaced the Config button, and the Axis Config  button changed.

Navigation Improvements

MIMIC has added a double-arrow slider bar above the Date Options and Worksheet Options panes:

You can use the Up Arrow  button open a minimized pane, or to enlarge an opened pane to cover the
entire interface. You can use the Down Arrow  button to return an opened pane that covers the entire
interface to its original position, or to minimize or hide the pane completely.

When you hover over the slider bar with your mouse, your cursor changes to a double arrow. You can then
click and drag the slider bar up or down to enlarge or reduce the size of a particular pane.
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Mouse Menu
In the Worksheet, MIMIC still allows you to select a row and press Ctrl C to copy the row and Ctrl V to
paste the row, but you can now also select a row and right-click to open the mouse right-click menu:

With this new right-click menu, you can copy, paste, delete and insert a new row. An inserted row appears
directly above your selected row.

Access to Charts and Tables from Browse Mode
After selecting a symbol via the Search Database window, you can now chart or table your Worksheet
data directly by selecting the Chart  button or the Table  button. You no longer need to select the
Configuration  button and return to the Configuration window first.

Sorting Tables
In this version, MIMIC allows you to sort any table column in ascending or descending order by clicking
on the column heading. You can also now set the default sort order for all future tables to ascending or
descending by selecting Options>User Preferences and then selecting the Table tab.

Ability to Skip Weekend Data
You can now remove weekend data (data from Saturdays and Sundays) from your analysis by selecting the
Skip Weekends option. You can only select this feature when using the following Execution Units: Days,
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Hours, Minutes, Seconds and Milliseconds. For the current Worksheet data, select the Skip Weekends option
in the Worksheet Options pane. For all future analysis, select Options>User Preferences and then select
the Table tab.

Switch Off Table Summary Statistics
MIMIC now allows you to to remove the table summary stats from your table. For the current or active
Worksheet, you can uncheck Table Summary Stats in the Worksheet Options pane. If you want to disable
this for all future tables, select Options>User Preferences and select the Table tab. Under this tab, uncheck
Show Summary Stats.

New Time Units Option - Avg Day Monthly
In the Series tab of the Data Builder, MIMIC users can now select the Time Units option "Avg Day
Monthly". This time unit displays as "1 Calendar Month Average of 1 Day Average of the Minute" in the
Worksheet. This new MIMIC feature is an averaging option, which you can apply to more than one row in
the Worksheet. By selecting Avg Day Monthly, MIMIC transforms intraday data into daily data values, and
then creates a monthly average from the daily data values. For example, a series can be transformed from its
default Time Units of "Minutely" (an intraday value) into a single monthly average value.

Improved Calendars
MIMIC includes updated calendars in the Date Options pane for selecting a specific Start or End date:
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Search Selection Defaults

If you need to search for a symbol, you can select the Search Database  button, select the symbol
information and either double-click or right-click and choose Select to add it to the Worksheet. If you return
to the Configuration window and realize you need to perform another search, you can then enter the Search
Database window again. In this latest version, MIMIC remembers the last search selection you made, so you
can browse to a new symbol from there.

Adding Favorites from Browse Mode
Within the Search Database window, you can add symbol information to your Worksheet. If you want to
add this symbol to your Favorites, you can simply select the row and then select the Add to Favorites 
button in the Worksheet Toolbar. You no longer have to return to the Configuration window first before
adding the symbol information in a row to your Favorites.

New MIMICExcel Toolbar

MIMICExcel now includes a toolbar with three buttons. From left to right, there is the Back to Excel 
button, which closes MIMICExcel and returns you to your Excel spreadsheet, the Query Manager  
button, which allows you to manage previously saved MIMIC queries, and the Embed Query  button,
which allows you to save or embed your current or active query.

LIM recommends that you use the Back to Excel  button to return to your Excel spreadsheet
instead of using the X button in the top right of the window.
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MIMIC queries are an important and popular feature. In this version, you save your query with greater ease.
When you select the Embed Query  button, MIMICExcel opens the Embed Query window:

In Embed Query window, you can not only enter a name for your query, but now a description too. This
window also allows you to set the starting location, or cell reference.

Now, for managing or embedding all queries in MIMICExcel, you can use the MIMICExcel toolbar
(the Query Manager  button or the Embed Query  button). And, for opening or saving all LLC
Worksheets (.llc files), you can use the standard MIMIC menu bar (File>Load, File>Save or File>Save As)
or the standard MIMIC toolbar (the Open  button or the Save  button).

Release 3.1.0.7
Please see the  MIMIC Release Notes  for information on bug fixes and minor software enhancements.

http://customers.lim.com/pdfdocs/mimic_release_notes.pdf
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Release 3.1.0.6

Favorites Browser
For consistency, the Hotlist Browser is now called the Favorites Browser.

XML Converter
MIMIC now features the ability to generate XML worksheet output directly from the File menu. Use this
feature to save new (current) worksheets or convert existing worksheets (.llc file type) to XML (.xml) format.
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Release 3.1.0.4

Synchronize Columns
The latest enhancement allows the user to change all the Columns for all the type Series to a specified
Column name.

The following instructions show how to synchronize columns:

1. Add a few series such as “NG”, “HO”, “CL” and “HU”.

2. Change “NG” column to “Open”.

3. Right click on “Open” in the Column field and select “Set All Columns to Open”.

All items of type Series that have the column selection of “Open” as a possibility will change to “Open”.

Synchronize Time Units
Synchronize all the Time Units for the type Series. The following instructions highlight the steps:

1. Add a few series such as “NG”, “HO”, “CL” and “HU”.

2. Change “NG” Time Units to “Weekly”.

3. Right click on “Weekly” in the Time Units field and select “Set All Time Units to Weekly”.

All items of type Series that have the Time Units selection of “Weekly” as a possibility will change to
“Weekly”.
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Fill Blank Option
In the Missing NaNs field we added the option to “Fill Blank”. This option will fill all missing data with a
blank. This is extremely useful in the Excel application when Excel formulas are calculating values based on
the results from a query.

The following graphic shows the Missing NaN field located in the bottom right-hand portion of the MIMIC
application.

Open and Rename a Saved Query in MIMICExcel
The dialog for opening and renaming a saved query in MIMICExcel is more intuitive. To open and make edits
to a saved query select “Edit”. To change the name of the query select “Rename”. To copy the query select
“Copy” and to delete the query select “Delete”.
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Release 3.1

Look and Feel
The MIMIC configuration window has a new look and feel for icons. Hover with the mouse over the icon to
get a description of the icon.

1. Icons replace text buttons to add (+) or remove (-) worksheet rows.

2. Top menu items now have “standard” size windows icons with no embedded description. Hover over
icon for description of function.

3. New Chart, Table and Configuration (looks like a wrench) icons replace buttons.

4. Configuration icon only appears in the top menu bar – not in the middle of the worksheet screen as well.

5. The Search for Symbols icon (binoculars) is no longer a text button. Hover over the icon for the icon
description.
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6. Heart shaped Hotlist Add and Hotlist Open icons have replaced the text buttons.

Multiple Data Selections in Tree View
To demonstrate this feature, browse through the tree hierarchy as normal down to the symbol level (green
dot = futures symbol, blue dot = normal symbol). At this point, a single click will highlight the symbol, and a
double click will open up its columns. If you want to select the symbol without opening columns, right mouse
click with the symbol highlighted and choose “Select” to add the symbol information to the worksheet.

While this may seem a little more long-winded for one selection, it permits you to use the Ctrl and Shift keys
to highlight multiple symbols before you use right mouse button to select – allowing for multiple selections at
once.

If you proceed down to the column detail, you can double click on a column to select or highlight multiple
columns and right mouse click to select all items highlighted at once.

New Search Mode Option
We are working hard to improve the experience for users searching for data in MIMIC.

There is currently a two pronged approach. Improve the search facility within MIMIC and create a first class
search facility on the LIM Website (Data Catalog) powered by Google, which provides specific information
about all the data LIM carries and has more familiar features of an Internet search.

LIM is also working on developing a direct link between the Data Catalog facility and the MIMIC software
– allowing users to dynamically leave MIMIC, make a catalog search and then choose catalog items and have
them directly selected as worksheet rows in MIMIC if they are available in the local database.

For this release, we introduce a more sophisticated and speedy search feature to allow users to reduce the area
of the hierarchy searched and quickly select database symbols and columns.
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You may narrow a search by selecting the category to narrow to or you may narrow using one of the
selections available from the pull-down list. The following graphic shows a search for “henry hub” that is
narrowed to searching only the symbols in the “Energy” category.

To narrow to a category other than the ones listed in the pull-down menu, select “Custom Narrow,” then
select the category you would like to narrow to from the hierarchy.
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View Chart Options
With a view to further development in 2006 to improve the MIMIC chart capability, we have opened up a
couple of features that give users more control of the legend placement on the chart and re-organized the
View Menu. The seasonal functionality has had a major reworking (see Seasonal Charts below).

The View Menu now has two levels of selection. The first item, View Chart Options, controls access to chart
grids, chart symbols, chart controls and chart legends as well as the orientation and anchor location of the
chart legends.

Previous View Menu options: (configuration, chart, table, query) appear as before below View Chart Options.
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Seasonal Charts
See the new functionality accessible via the “Seasonal Analysis” check box on the Configuration window.

Selecting the Seasonal Analysis check box results in a dialog box being shown that guides the user through
appropriate seasonal selections.

The date range for seasons is set so that you can easily select the period of the year and the number of
seasons that you want to analyze – whether that be in a chart or in a table. The “Lock” feature automatically
selects all seasons between the chosen start date and the end date, which you can then choose to display or
not using the check boxes for table or chart.

Seasonal averages can be selected using the Average Tab in the seasonal dialog. The default is a seasonal
average of all seasons to be analyzed. You can switch off the default average display in a chart or table and
you can also create custom seasonal averages which do not include all years.
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For the convenience of users, the chart and table buttons in the seasonal dialog allow direct access to the
chart or table.

The new seasonal chart functions allow multiple seasonal averages to be displayed for multiple different
items. Seasonal charts may now have multiple axes (controlled by the Edit Axis Config dialog). Averages are
calculated for all visible worksheet rows.
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Upload or Export Symbols and Columns from a .txt or .csv File
This facility allows users to create a list of required MIM symbols and columns in a text file (may be created in
Excel and saved as a .txt or .csv file). From the MIMIC menu select “File>Import Symbols”.

These items may then be loaded directly into MIMIC to create a worksheet. This helps an analyst that has a
new list of symbols generated by (for example) an external system.

In the same way as you can import symbols and columns, it is also possible to “export” the relevant symbols
and columns from a MIMIC worksheet out to a text file.

Release 3.0.2.2

Updates for MIMICExcel
The MIMICExcel Open dialog for copying, deleting and renaming files now performs these functions more
optimally. (To access MIMICExcel, open Microsoft Excel and select the MIMICExcel icon). Select the
“Open” icon from the toolbar.

You must have saved queries to view this feature.
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The Open dialog has the following choices: “Open”, “Copy”, “Rename” and “Delete” (note: “naturalgas” is a
saved query).

Copy

The copy function is now more user-friendly. (Note: for instructions on how to move data please the section
below on “Moving Data within a Spreadsheet”.)

1. To copy data to a new location in the spreadsheet select the saved query from the list then select “Copy”
from the Open dialog. Enter a new name for the query then select “OK”.

2. The Copy Location dialog displays. Select the icon noted in the graphic below to go to the Excel
spreadsheet.

Once in the spreadsheet, select the cell where you would like the data to display then select the icon
(noted below) to return to MIMICExcel. Select “OK” to confirm the location choice.
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3. In the spreadsheet select the MIMICExcel “Refresh” icon to display the copied data in the spreadsheet.

Delete
This feature used to leave behind comment information (comment information is text that displays when the
cursor is hovered over a spreadsheet cell). When a query is deleted from the list note that data already placed
in a spreadsheet will not be removed. To remove data already placed in a spreadsheet, select the data then
right click with the mouse and select “Clear Contents”.

Rename
The “Rename” feature is now more user-friendly. A dialog window now displays for the user to enter a new
query name.

Moving Data within the Spreadsheet
To move the query data from within an Excel spreadsheet simply select, then cut and paste the data (use the
keys Ctrl+X to cut and Ctrl+V to paste) to a new location in the spreadsheet. (Note: Use cut and paste—not
copy and paste—to move the data. Copy and paste will not move the reference to the query.)

Update for MIMIC

Moving Rows with Ctrl + Arrow Keys
Previously, to move a row up or down in MIMIC you would click in the row (a highlight will appear around
the cell) then use the arrow up or down keys to move the row up or down. Now, use the Ctrl+arrow keys to
position the row. Remember, you can also copy and paste a row using the Ctrl+C and Ctrl+V keys as well.
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Release 3.0.2

New Interface Design
MIMIC has a new layout in the bottom portion of the interface. The Date Options are separated from the
Worksheet Options for easier navigation.

Prior to release 3.0.2, the MIMIC interface had specific Change Period numbers listed (i.e. 1 day, 2 days, 1
week, and 2 weeks). Now, the Change Period has an up and down toggle where you can specify any number
of days/weeks/months/years.
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Old Design: (Bottom portion of the MIMIC interface.)

New Design: (Bottom portion of the MIMIC interface.)

In addition to the Change Period functionality, there are new calendar icons next to the Start and End Dates.
Use these calendars to select the date entries if desired.
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Add Contracts Enhancement
The Add Contracts feature has been enhanced so that the user is now alerted when a symbol does not
contain any data for a specific column.

For example, in MIMIC releases prior to 3.0.2, if you selected “Add Contracts” on the symbol “NG” with the
column “ImpVol” for the date range “January 2005” to “December 2007” the relevant contracts would list
and there would not be any error message, even though ImpVol did not exist for some contracts. When these
results were tabled, MIMIC would return the message “error no data returned”.

Now, MIMIC lists the contracts that do not contain any data for a specific column. When running the “Add
Contracts” feature on the example above, the following message will now display if there are contracts with a
column that does not contain any data:

Example:

Step 1: Enter the symbol “NG” and select the column “ImpVol”. Choose “Add Contracts”.

Step 2: Enter your dates “January 2005” to December 2007”. Then select “OK”.
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The following message will display:

Next, select the Java Console by selecting “Help>Java Console” from the MIMIC menu bar:

The Java Console will list all the rejected contracts that do not contain any data:

Find the Last Known Value using Fill End
There is a new fill option in MIMIC that enables a user to retrieve the last known value(s) for a symbol for a
specified date range. For instance, on a Monday morning, you might want the last known value for the Close
of “CL”. MIMIC now has this functionality. Using Fill End with a few other settings, the value returned will
be Friday’s closing unless Friday is a holiday and then the last known value will be returned.
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The following graphic shows how to retrieve the last known value for the Close of “NG” for “February 25,
2005”. (Note: The graphic shows the bottom portion of the MIMIC interface.)

Select the End Date “02/25/2005, uncheck “Skip All NaN” and select “Fill End” for the Missing Data
NaNs. The Change Period should be set to “0” “Days”.

If today is 02/25/2005 (before the market closes) then the value returned when the results are tabled is the
value from the closing the day before on 02/24/2005.

To find the last known value for a date range—for instance, the last known value for the last 3 days—enter
“2” “Days” for the Change Period.

Curve Matrix Tool only Allows OHLC Columns
This is a bug fix for the Curve Matrix Tool. (Access the Curve Matrix Tool from the MIMIC menu bar:
“Tools>Curve Matrix”.) The Curve Matrix Tool should only return values for the columns Open, High,
Low, and Close (OHLC). Previously, if a column other than OHLC was selected (for example, the column
“ImpVol”) then MIMIC would ignore the column selected and default to showing the values for “Close”.
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Now, when a column other than OHLC is selected, the “Curve Matrix” menu selection is not accessible from
the menu bar. The following graphic shows an example:
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New Save Obligation in MIMICExcel
When working in MIMICExcel, a “Save Query” dialog will display when the “Table” icon is selected to table
the results of a query.

This new feature prevents users from accidentally losing data when their MIMIC queries have not been saved
and Excel is closed.

Advanced Refresh Narrows Date Range in MIMICExcel
This enhancement allows a user in MIMICExcel to modify a date range for a given MIMICExcel query. This
prevents a user from having to open and modify the date range for each item in a MIMICExcel query.

The following example demonstrates how it works:



34 MIMIC PRODUCT NEWS

1. Open Excel, then create a query with date ranges of February 28, 2001-February 28, 2005 for each item
added. (The graphic below shows a portion of the MIMICExcel window.)

2. Select “Table” to put the results of the query into an Excel spreadsheet. (The graphic below shows a
portion of the spreadsheet.)
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3. Now to demonstrate how to narrow the dates without modifying the date range for each item in the
query. First, clear the data from the spreadsheet by highlighting the data, then right-click and select “Clear
Contents”.

4. Select the cell where you want the data to begin populating. For this example, select cell “A:2”.

5. To narrow the date range, turn on the Advanced Refresh Mode by selecting “MIMIC>Advanced Refresh
Mode” from the menu bar.

6. Select the Refresh icon from the MIM Excel Add-in tool bar.
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The following dialog displays:

7. Enter a Start and End Date. Select the  icon to use the calendar to choose the dates if desired. For
this example, let's narrow the dates to July 1, 2003 - July 15, 2003. Keep "All Worksheets" selected then
choose "OK" to continue.
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“All Worksheets” – updates all queries on all worksheets found in Excel whereas “Active
Worksheet Only” will only update queries on the worksheet that is currently in use.

The spreadsheet will populate narrowed to the requested date range:

Fixing Invalid Targets in MIMICExcel
The following graphic in Excel denotes that a cell contains a reference to a MIMIC query:

If this cell containing the query reference gets deleted than the results cannot be posted into Excel and an
“Invalid Target” message displays. In version 3.0.2, the “Invalid Target” dialog is enhanced to display all the
invalid query messages in one dialog window. Previously, a separate dialog window displayed for each missing
query target.

Example - How to Fix an Invalid Target
1. Create three separate queries in MIMICExcel and table the results into an Excel spreadsheet. Name the

queries “ng”, “cl” and “ho”.

2. In the spreadsheet, highlight the row(s) containing the query references. Right-click and select “Delete” to
remove the query references.

3. Refresh MIMICExcel by selecting the Refresh icon or select “MIMIC>Refresh MIMIC Queries” from
the Excel menu bar. The following dialog displays.
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4. Here’s how to re-establish the missing targets. Enter MIMICExcel by selecting the MIMICExcel icon or
“MIMIC>Enter MIMIC” from the Excel menu bar.

5. Select the “Open” icon. When the “Invalid Targets” message displays, select “OK”.

6. Select one of the queries listed in the “Invalid Targets” dialog then select “Edit. Use the following icon to
choose where to store the results of the query:

7. After selecting a valid cell, return to the MIMICExcel window and select “Save”. Repeat steps 4-7 for
each query that needs to be restored in the spreadsheet. Now when the MIMIC Refresh icon is selected
the query results will post in the spreadsheet.

Release 3.0.1.6

Weekly Seasonal Analysis in Tables
The table formatting for displaying the results of a seasonal analysis with weekly execution units selected has
been enhanced. Instead of displaying the dates for each Friday occurrence the year is broken into 52 weeks
and the date is displayed as “Wk #1”, “Wk #2”, etc.
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The following graphic demonstrates the old method for displaying the dates. (The date displayed is the Friday
for each week.)

The new formatting uses the dates labeled per week:



40 MIMIC PRODUCT NEWS

Release 3.0.1.5

MIMICExcel - Sheets Dialog Enhancement
MIMIC can be used through the Excel interface; this LIM product is referred to as MIMICExcel. When
opening saved table results from MIMICExcel, the interface now shows the exact spreadsheet cell location
where the results were saved to:



MIMIC PRODUCT NEWS 41

MIMICExcel - Date Formatting
In MIMIC, the date format may be changed in the Users Preferences dialog (select “Options>Users
Preferences”, “General” tab). In MIMICExcel the Data Format field is now grayed out or disabled as all date
formatting should be done through Excel.

Release 3.0

MIM Screening System
Finding quality stocks just got easier. Use LIM’s Screening System to screen for: Cash Flow, Earnings Per
Share, PE, Market Value, Net Profit Margin, Price, Ratios, Return, Sales Per Share and much, much more.
With the LIM Screening System you can quickly search over 12,000 stocks from the COMPUSTAT®

Quarterly data set (universe). Pick the specific exchange(s) you would like to search over. Then, using Actual/
Percentile, Minimum/Maximum, Time Period and Rank settings, narrow the playing field even further to find
the stocks matching your criteria.



42 MIMIC PRODUCT NEWS

Once you have your results you can use MIMIC to chart or perform further technical analysis on your
fundamental stock results. Everything you need to fine tune your stock picking and trading/investing is in one
package, ready to go.

To get started using the Screening Tool just open the MIMIC application and select the “Screening Tab”.
Make your criteria selections (organized by folders), enter the screening values (Actual/Percentile, Min/Max,
and Rank), mark the checkbox and select the “Run” button.

The results, displaying in the “Answers” portion of the window are organized to always show the % Return
per Quarter, the % Compounded Quarterly Growth, the results of a $10K investment and the results of a
$10K investment compounded quarterly.

With the MIM Screening Tool you can quickly find the high volume stocks, the stocks with the greatest sales
revenue or largest market cap, find stocks with the strongest forecasted growth, or search out the stocks that
are not doing well in the market. These are just a few examples of the types of screens that you can do.

To demonstrate the Screening Tool, let’s look for companies listed on the New York Stock Exchange that fit
our criteria for being well-managed companies. We want to search for companies over the last four quarters
that are effective at cost control, that are not highly leveraged, and that are effective at generating profit with
existing shareholder resources. To perform this study, enter the following screening criteria:

For Cash Flow and Earning per Share, choose to look for companies in the top 2 percentile of all stocks in
the stock universe and rank them from highest to lowest.

For the Debt-to-Equity Ratio, we want to see just those stocks with an actual D/E between 0.01 and 4 and
rank the results from lowest to highest.

Finally, to eliminate penny stocks from the results, choose actual prices higher than $5.00 without any rank
necessary for this analysis purpose. Select from the last month quarterly close price.
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Next, set the time period to “4” to screen over the last 4 quarters.

The Screening Tool returns three stocks out of the universe that show effective management potential:
“BDY”, “MXO” and “EVG”.

For each quarter that the user’s criteria is met, the results display the following four shaded rows for each
symbol returned: “% Return per Quarter”, “% Compound Quarterly”, “$10K Becomes”, and “10K
Compound Becomes”.
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● % Return per Quarter: The simple percentage return for each quarter.

● % Compound Quarterly: The Compound Quarterly Growth Rate – Cumulative: The compound quarterly
rate calculates the compound quarterly return from the beginning of the chosen period to the last.

● $10K Becomes: The simple return of $10,000 for each quarter.

● $10K Compound Becomes: The compound return of an initial $10,000 investment at the beginning of the
study.

The remaining results are discussed below and have the following implications:

● Close3: The Close price of the stock for the 3rd month of a quarter.

● cash-flow-1-year: We wanted to find companies in the top 2 percent of all companies. BDY is in the 100
percentile for the last 3 quarters.

● pct-return-qtr (Return Per Quarter): Displays the 1 quarter percent move of the stock.

● debt-equity-ratio: We screened for stocks that have a low D/E ratio (between 0.1 and 4.0). BDY shows a
D/E of less than 1 for the last 4 quarters.

● eps-basic-eei-1-year: The screener returned our eps criteria. We chose companies in the top 2 percentile.
BDY is in the top 99 percentile for the last 4 quarters.

● Ranking: Based on a pre-determined formula, the ranking calculation orders the results matching all of our
screener variables from best to last. Notice that BDY best matches our criteria in each category. Therefore,
it ranks much higher than MXO and EVG. In fact, BDY matches our criteria in each of the last 4 quarters.
MXO and EVG only match our criteria in just one of the last four quarters.

By screening only over the COMPUSTAT Quarterly universe, the time it takes to find your stock
fundamentals is tremendously reduced. This universe may be customized for your specific usage. For more
information, see the document “MIM Screening System, System Administrator’s Guide” or contact a LIM Sales
Representative at sales@lim.com.

Use MIMICExcel to post MIMIC Tables Results into Microsoft Excel®
The full functionality of MIMIC is now at your fingertips while working in Excel.

To obtain this functionality, make sure you have MIMIC version 3.0 or higher installed on your system. For
details on installing the MIMIC software, see the “Client Application Installation Guide”. This document
covers the highlights of the new tool. For functionality details and working examples, see the “MIMIC
Training Guide”.

mailto:sales@lim.com
http://customers.lim.com/pdfdocs/install_limapps.pdf#MIMIC_Installation_and_Purchase_Options
http://customers.lim.com/pdfdocs/mimic_training_4.pdf
http://customers.lim.com/pdfdocs/mimic_training_4.pdf
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After installing MIMIC 3.0 or higher, start the Microsoft Excel program and note that there are two new
icons on the toolbar:

Select this icon:  to open the MIMIC window.

Another Option is to select MIMIC>Enter MIMIC from the Excel menu bar.

The MIMICExcel window contains the full functionality of MIMIC in addition to the following: 1) there is a
button for designating which cell in the Excel spreadsheet to store the results of your table. 2) there is a “Back
to Excel” button for returning back to the Excel spreadsheet.
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The graphic below shows the MIMICExcel window with a query entered.

To table the results of the query and have the results display starting in cell A:1 of the spreadsheet, select the
table icon in the toolbar.
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The results display in the Excel spreadsheet (see the graphic below).

Formula Expression Builder
LIM brings an exciting new capability to MIMIC users: a custom formula expression builder that allows
formulas to be saved as relation names in the database for reuse in MIMIC queries. On the MIMIC interface
there is a “Stored Formulas” tab. When activated, a user can create formulas using LIM’s proprietary near-
English query language. Formulas are easily created and shared by users. Since a formula is stored as a
relation, the formula can be used in MIMIC just like any other relation providing a huge savings in time
management. For information on installing the Formula Expression Builder, see the “Client Application
Installation Guide” located on the LIM website. For more details on using the Formula Expression Builder,
see the chapter on “Creating Custom Formulas” in the MIMIC Training Guide.

The graphic below shows how to get started creating custom formulas. Select the “Stored Formulas” tab to
enter the custom formula building area.

http://customers.lim.com/pdfdocs/install_limapps.pdf
http://customers.lim.com/pdfdocs/install_limapps.pdf
http://customers.lim.com/pdfdocs/mimic_training_4.pdf
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The Formula Window
The formula building window is divided into three areas.

Section 1 – Formula Variables and Symbol Information Areas:

At the top, users select their formula variables in the same way that they select new rows for a regular
MIMIC sheet. The section underneath “Symbol Information” displays the details of the selected rows
(relation name, units and column information).

Section 2 – MIM Schema Browser:

At the bottom left is the MIM Schema Browser area where you can select your variables by browsing for a
“Variable” and can review or edit your formula by browsing for a “Formula”.

When the “Import as: Variable” radial is selected, variables selected can be used to build the formula
expression. Alternately, the “Import as: Formula” radial selection allows the user to open a formula for
editing. A formula is selected by opening the formula folder and double clicking the “Value-Value (sparse)”
entry. The formulas are saved in a special area on the database, under the “Users>username>Formulas”
directory.
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The refresh icon,  located in the bottom right-hand corner of the MIM Schema Browser is useful when
you want to quickly close all the folders in the browser window and locate a new relation item or formula.

Section 3 – Formula Specifications:

The section under “Formula Specifications” is the formula expression definition area where you provide a
name and description for your formula and then define the formula expression.

Formulas are easily shared with other users to reuse and build upon as needed. Just find the formula you
would like to use, and save it with a new relation name. The formula is then added to your own directory
and may be revised and reused as desired.

Building a Formula

It’s easy to build and save a formula expression. This is how a formula will appear when completed:



50 MIMIC PRODUCT NEWS

To see detailed instructions for building a formula, see the chapter on “Creating Custom Formulas” in the
MIMIC Training Guide.

Validating a Formula

After building a formula, it may be validated to ensure that it will run without problems. While in the Formula
area, from the menu bar, select “Tools>Validate Formulas”.

Using a Formula in a Query

The formula is now ready to use in a query. Select the MIMIC tab to leave the formula area.

Make sure the Series icon  is selected, then click on the Browse button, open your Formula folder
(Users>username>Formulas) and select the formula named “MAYA_CONTINUATION”.

http://customers.lim.com/pdfdocs/mimic_training_4.pdf
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The formula populates the query builder in Row A. This expression can be used easily on the fly and is
available to any user.

Curve Matrix Tool
The Curve Matrix tool generates a specific type of request to the MIM database from within MIMIC. The
tool only works with the parent symbols of futures commodities. Row A of the MIMIC worksheet must
contain a futures parent symbol, such as NG (NYMEX Natural Gas Futures). After entering a futures symbol
in Row A of the worksheet, the Curve Matrix is accessible from the “Tool” menu on the MIMIC menu bar.

The Curve Matrix tool allows users to define a range of history (default is all history), over which daily
forward curves of the specified futures commodity will be generated in a table form as a .csv file (which can
be easily imported into Excel). The forward curves data structure that the Curve Matrix tool generates is an
absolute pattern of quotations. In other words, forward month quotes for any date in the range are returned
as an array of values, the positions of which are always fixed relative to the quote date out along the array in
monthly increments. If there are no quotes for a particular contract month out along the curve, that position
contains a blank entry, so that all adjacent entries are equidistant in delivery month from the left of the data.

This kind of curve matrix is particularly useful in risk management calculations for Value at Risk (VAR) type
models.

Create the Curve Matrix
1. Enter the MIM symbol NG and select “Enter”.
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2. From the MIMIC menu bar select Tools>Curve Matrix. The following window shows the Curve Matrix
tool with date and file entries:

Enter the following information into the fields so that your entries match the graphic below. For a
detailed description of the fields, please see the chapter on the “Curve Matrix Tool” in the MIMIC Training
Guide.

3. Selecting the “Start” button initiates a procedure to create the files directly from the MIM database. If the
user has selected a long date range or all data for a particular contract, the server may take some time to
generate the files. The line “Curve Matrix Complete” in the progress console tells you that the procedure
has finished.

4. To view the results, go to the working directory (c:\lim\mimic) and open the two files “sample1.csv” and
“sample2.csv” (these files can be opened in Excel). The following graphics show portions of the files:

Sample1.csv (Shows the NG contract names)

http://customers.lim.com/pdfdocs/mimic_training_4.pdf
http://customers.lim.com/pdfdocs/mimic_training_4.pdf
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Sample2.csv (Shows the values of the NG futures contracts)

Note that the question marks indicate a holiday where no trading takes place.

New Date Ranges
You can now choose “1 Day”, “2 Days” or “1 Week” from the Changer Period pull-down menu from
MIMIC. Please see the graphic below:
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Reorganized User Preferences Dialog
The User Preferences now has a new format for the dialog window. Select the User Preferences from the
Options menu on the MIMIC menu bar. The graphic below shows the new dialog:
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Round Mode
In the User Preferences dialog (from the MIMIC menu bar select Options>User Preferences), under the
General tab, there is a new feature called “Round Mode”. The round mode determines how MIMIC will treat
rounding when the user selects a precision for the series that is less than the number of decimals in the value
returned (i.e. precision selected is 2 decimals, the number is 3 or more decimals).

In such cases, the user can now specify the rounding technique used by choosing between 3 alternatives:

1. Round “half even” (the default) will round any trailing 5 up or down to the nearest even number (i.e.
if the decimal precision is two decimals and the number to be rounded is 2.345, the calculation rounds
down to the nearest even value at 2.34, whereas if the number to be rounded is 2.355, the calculation
rounds up to the nearest even value at 2.36.)

2. Round “half up” will always round the trailing 5 up.

3. Round “half down” will always round the trailing 5 down.

Look and Feel
Change the look of your window display by choosing a listing in the “Look and Feel” submenu.
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Release 2.1.3

Print Options
The Options menu has a new tab: “Print Options”. To access the Options menu, select “Options” from
the MIMIC menu bar. Select the “Print Options” tab to set a table to print in either landscape or portrait
orientation.

Release 2.1.2

Weekly and Quarterly Averages
In addition to monthly averages, MIMIC is now able to chart weekly and quarterly averages. Just make your
selection from the Time Units pull-down window.
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The weekly average gives you a weekly average of values in the date range. For 5 day trade pattern data, the
weekly average values are returned every day of the week if you select “daily” execution units or once a week
on Fridays if you select “weekly” execution units. The weekly average is a 5 day average – Monday through
Friday.

For a seven day trade pattern series, a seven day average from Monday to Sunday is returned every day of the
week if you select “daily” execution units or once a week on Saturdays if you select “weekly” execution units.

The default weekly average calculation can be changed using the missing data NaNs option to address any
missing data. If you prefer to return weekly average results on a weekly basis on a different day of the week
(other than Friday) or if you want to calculate the average differently at weekends rather than during the week
or over a different start and end day than Monday to Friday (or Monday to Sunday), please ask for advice
from the LIM customer support team.

The quarterly average shows the average of values during the current quarter returned on a daily basis if the
execution units are set to “daily”. The results will show once a quarter on the last day of the quarter if you
choose “quarterly” execution units.
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Release 2.1.1

New Graphical User Interface (GUI)
The new interface design is more consolidated and easier to read because the main data types (series, formula,
curve) each have their own tab and some details are now accessed via a button instead of displaying on the
main screen (e.g. “Edit Chart Stats” – the statistic choices). Also note that the description field is wider
allowing more room for editing and better utilization of the space.

Upon opening MIMIC, the display or Configuration Window will appear as illustrated in the graphic below:

The Configuration Window is divided into two main areas: the Worksheet area and the Data Builder area.

By selecting the icons for Series, Formula or Curve the Data Builder area of the Configuration Window now
changes to show only the information pertinent to building the selected format.

For example, the following graphics show the display when the Series, Formula and Curve icons are selected.
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Creating a Series

The following example shows the display when the Series icon is selected.
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Creating a Formula
When the Formula icon is selected only the formula information displays in the Data Builder.
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Creating a Curve

The following example demonstrates the Data Builder display when the Curve icon is selected.
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Edit Chart Stats - Statistic Choices

The statistic choices are now available from the “Edit Chart Stats” button. (Previously the statistic choices
were available directly from the Data Builder display area.) This allows for better usage of the Data Builder
display area.

When the “Edit Chart Stats” button is selected the user sees the following statistic choices: “Max”, “Min”,
“Average”, “Last”, “Std Dev” and “Apply to All Items”.
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The “Apply to All Items” selection allows the user to apply the settings to other rows in the
Worksheet.

Hot Keys

The following hot keys are now available from the top menu bar in MIMIC:

ALT+F File

ALT+E Edit

ALT+V View

ALT+O Option

Under the File menu are the following hot keys:

ALT+N New Worksheet

ALT+L Load Worksheet

ALT+S Save Worksheet

Under the Edit menu are the following hot keys:

ALT+R Remove Item

ALT+A Add New Item

ALT+I Insert New Item



64 MIMIC PRODUCT NEWS

Refresh Button
Use the “Refresh Button” in the Chart and Table areas to update the data being viewed. This is useful when
working with intra-day type data where the MIM database is being updated frequently and the chart or table is
not dynamic to this new data.

Pre-Calculated Continuation Series in MIMIC
We have now distributed pre-calculated continuations for the energy futures data to MIMs. The data resides
in the “Continuous” folders under each of the following contracts:

● CL – 24 month series

● NG - 24 month series

● HU - 12 month series

● HO - 18 month series

● FB - 12 month series

● FP – 12 month series

There are two types of continuous data available:
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1. “N” Month Out Continuation Series

The folder contains relations such as CL_02, CL_03 out to CL_24 which represent the 2nd through the
24th month out continuation series with rollover set at “expiration date”.

These series are provided as pre-calculated MIM relations (although they can be custom built using
the MIMIC “Adjust Contract” feature that allows you complete control over rollover data and rollover
policy).

The advantage of having the series set up as relations is that they can be more easily referenced by the
API’s or in a spreadsheet without using an expression. Also, because the series is pre-calculated, it will be
returned to an application more quickly.

2. Continuous Calendar Month Series

Continuous folders also contain "Monthly" Continuation series that are pre-calculated. These use futures
contract month letters to identify the month, so that:

CL_F = January Crude
CL_G = February
CL_H = March
CL_J = April
CL_K = May
CL_M = June
CL_N = July
CL_Q = August
CL_U = September
CL_V = October
CL_X = November
CL_Z = December

For each month, the series represents a continuous nearby contract for that delivery month. CL_F is
January Crude nearby – a series that always looks for the nearest January crude contract etc.
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