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CHAPTER 1

Getting Started

Objectives
Learn about the following MIM Excel® Add-in features:

1. Add data using the following methods: browse data, search symbols, search descriptions and select a
recently used data item.

2. Merge and edit data
3. MIM Queries/Run All Queries
4. Get Records
5. SHOW/WHEN
6. Forward curve
7. Load Data
8. Get Options and the Options Facility
9. Using MIMICExcel

By installing MIMIC, version 3.0 or higher, you have access to MIMICExcel. This
functionality will enable you to create queries and post the results easily to an Excel
spreadsheet. See the “MIMIC Installation and Purchase Options” chapter in the Client
Application Installation Guide for more information on installing MIMIC to have this
functionality.

10. How to pass the results of a MIM query into the cell of a worksheet with XMIMGetData.
11. Set configuration options and decimal place settings
12. How to get help

http://customers.lim.com/pdfdocs/install_limapps.pdf#MIMIC_Installation_and_Purchase_Options


2
 

MIM EXCEL ADD-IN TRAINING GUIDE
Chapter 1: Getting Started

Installing the MIM Excel Add-in
Go to the LIM "Downloads" Web page and download the latest MIM Excel® Add-in software file. For
installation instructions, see the chapter "MIM Excel Add-in Installation" in the Client Application Installation
Guide.

You must have Java version 1.4 or higher. To obtain a free Java download, go to: http://
www.java.com.

http://customers.lim.com/download/download_prodsoft.html
http://customers.lim.com/pdfdocs/install_limapps.pdf#MIM_Excel_Add-in_Installation
http://www.java.com
http://www.java.com
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Overview
The MIM Excel Add-in software provides direct access to time series data from a MIM server. Using the
MIM menu, users can extract daily futures prices and many other data series. The MIM add-in is a client
application for the MIM server. The MIM server provides time series data to the enterprise over the network.

The MIM Excel Add-in creates the MIM menu on the Excel menu bar. Using the MIM menu, users can
create requests for data and populate Excel worksheets with values. The requests are saved in the Excel
workbook using a hidden worksheet.

Highlights of the MIM Excel Add-in:

● Data requests are created and edited using a step-by-step wizard dialog.
● Includes an integrated MIM schema browser and schema search to locate data.
● Includes support for units of measure conversions.
● Features several types of futures contract reshaping, including prompt contract offsets and several

switching day policies.
● Data requests are stored in the Excel workbook in a hidden sheet. Data refresh is a single click menu

operation.
● Workbooks with data requests can be attached to emails and used by any other user with the MIM Excel

Add-in software.
● The functionality of MIMIC is available while working within Excel.

The steps for creating data are:

1. Request data using the data browse, symbol search or description search.
2. Refine data using date delimiters.
3. Refresh the worksheet to display the data.
4. Specify the location on the Excel worksheet to create data.

Once the MIM Excel Add-in is installed, Excel will have a new menu item labeled MIM.
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The following provides details on each menu item.

The MIM Excel Add-in menu items perform the following tasks:

● Refresh Data - Refresh the data in the workbooks by downloading the data from the MIM server.
● Add Data - Add a new data item to the MIM. Data requests are configured in the workbook.
● Edit - Change the parameters of previously created MIM data requests.
● Run All Queries - Runs all queries setup by the user.
● MIM Queries - Create and edit queries in this menu.
● Get Records - Run queries on multiple data blocks.
● Show When - Create Show/When queries easily within one dialog menu.
● Forward Curve - Create a Forward Curve chart from a user selected futures contract.
● Load Data - Enter data from an Excel spreadsheet into the MIM database.
● Get Options - Use Get Options to access the special columns established for analyzing options.
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● Get Financials - Functionality no longer available.
● Options - Set network parameters and decimal place settings.
● Help - Information about the MIM Excel Add-in such as version number and access to the Excel Web

pages and Online Tour on the LIM Web site.
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CHAPTER 2

Refresh Data

Refresh Data from the MIM Menu Bar
Refresh Data runs all data requests that have been setup with Add Data (they go into MIM>Edit as a
list). These are normal data retrieval requests. In addition, all MIM queries that have been stored are run.
Remember that all data requests and MIM queries are stored locally in the .xls spreadsheet file. If nothing is
present in MIM>Edit or MIM>MIM Queries nothing will be returned.
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Auto-Refresh Data
By following the Visual Basic instructions below, a user can set the Add Data and query results to
automatically refresh when an Excel spreadsheet is opened.

Visual Basic Instructions for Auto-Refresh
To auto-refresh the MIM data, you need to run a Visual Basic subroutine with a RunAll statement within an
Excel Object. To accomplish this, do the following steps:

1. From the menu bar in Excel, select Tools>Macro>Visual Basic Editor.

2. Double click the ThisWorkbook icon (as shown in the graphic below).

3. Insert the following code:

Private Sub Workbook_Open()
   Application.Run (“MIMExcel1_1.xla!RunAll”)
End Sub

4. Save the changes.

The workbook (.xls file) you have made the changes to will now automatically refresh when opened. The auto
refresh only applies to the workbook you have saved the settings to. Repeat these steps on any workbook files
you would like to automatically auto refresh when opened.
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CHAPTER 3

Add Data

This is a wizard that allows simple data retrieval requests to be setup. The first step to begin requesting data is
to select Add Data from the MIM menu.
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Find a New Data Item
This is the first dialog in the add data process. There are four ways to determine the MIM symbol and
corresponding column information for the data request. This lesson will take you through each data request
method, beginning with a Browse Data example.

The four data request methods are:

● Browse Data - allows you to look through the database manually. This is a visual map to all data contained
in the MIM database. You are placed at the top level of the database i.e., TopRelation. Double-click
through the categories to navigate. The database is organized by market area. You can also use the folder
buttons to go up and down through the categories.

● Search Symbols - performs a search on MIM symbols contained in your database. Enter a symbol to
search for and the symbol along with its description will be returned. You can direct the search to be case
sensitive and also limit the number of answers returned.

● Search Descriptions - performs a search on MIM symbol descriptions. You can direct the search to be
case sensitive and also limit the number of answers returned.
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● Select a Recently Used Data Item - If data requests have already been made, you can request a recently
created data item.

To clear the display of the Recently Used Data Items, delete the WzRcItms.xmi file located
in the C:\LIM\XLA1.1 folder. This file will be re-created when a new Data Item is used.

Click on Browse Data in the Excel dialog and then proceed to the next step.
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Browse Data Example
The MIM browser displays the schema of the MIM server. The schema consists of categories (folders),
relations (symbols) and columns (fields). By double clicking on the categories, you can drill down into the
folders and locate the symbols available there. Once you reach a symbol, the browser will display the available
columns.

Let’s look at an example that locates the symbol CL that stands for Crude Oil, Light Sweet Futures.

From the Excel dialog, double-click on Futures or select Futures then click the folder button with the down
arrow. 

Next, double click on Nymex or select Nymex and the folder button.
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Your browser should now look like the graphic below. Select CL – NYMEX: Light, Sweet Crude Oil
Futures in the left-hand column. In the right-hand column, select Volume, then select Next>>.
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Select the desired date and time range.

The following outlines the date, time and data retrieval options:

Get Data From

a. Choosing the start of the available data will make the start date the first available data point date.
b. Choosing the last…N Time Period will narrow down your start date by your selections. (e.g., 3 months,

10 years, 7 quarters)
c. Selecting a specific date and time will take normal mm/dd/yyyy calendar dates. If there are specific

time constraints for the data, you will need to also specify a time.

Get Data To

The end date for the data is chosen here.

a. the end of the available data will make the end date the last data point in the database.
b. a specific date and time will take a normal date and/or time for the data to stop.
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Additional data retrieval options

a. Use data resolution of N Time Period. This option defaults to 1 day (e.g., Daily). Sometimes you may
have a need to look at weekly, monthly, or yearly data. The time period has a pull-down menu for this
choice.

b. Fill missing data points with X. A default NaN is filled if there is no data point available for a given
date. You can pull this down to have the data filled in other ways (e.g., Fill forward or backward, linear
interpolated values, logarithmic interpolated values)

c. If you have a real time feed connected to the MIM server, check Use Current Tick Data. (Consult your
LIM System Administrator as this is not common)

d. Finally, if you’d like MIM generated summary statistics to go along with the data request, check Include
Summary Statistics. The statistics included are: Sum, Average, Average Positive, Average Negative,
Percent Positive, Percent Negative, Highest, Lowest, Standard Deviation, Z stat, and Variance.

After entering your date information, click on Next>> in the Excel dialog and then go to the next step in the
lesson.

This part of the Excel dialog shows where the data will display in the Excel workbook. Select the cell in the
Excel workbook where you want the data to display.

Another method is to select the bar next to the destination cell.  The MIM Data Selection dialog
closes and the Excel Worksheet opens. Select the desired cell to store the data, then select the  button to
return to the MIM Data Selection dialog.



16
 

MIM EXCEL ADD-IN TRAINING GUIDE
Chapter 3: Add Data

The following outlines the destination, data placement and formatting options:

Returned data starts at cell

This is where the first date will be placed. The first data point will be in the cell immediately to the left.
You can type the location directly (e.g., Sheet1!$B$1), select the cell in the Excel spreadsheet or select the

 button.

Additional Data Placement and Formatting Options (check which ones)

a. Merge Data and Time Columns into a single column for adjacent data requests. By default all
adjacent requests with the same time parameters are merged to have a single data column. If you uncheck
this box, the requests will overwrite the data into the sheet.

b. Add column headers using Symbol and Column. This option will add the symbol and column as a
header to the request.

Example:

Date MSFT (Close)
4/19/99 81
4/20/99 83.125
4/21/99 82

c. Add column headers using Symbol Description. This option will enter the symbol description as the
header.

Example:

Date Microsoft Corp (CUSIP 59491810)
4/19/99 81
4/20/99 83.125
4/21/99 82

d. Clear the cells in the column of the range. This will clear any other data contained in the destination
column every time the request is made.

e. Clear the cells adjacent to the range. This will clear data that is not separated by empty cells around the
range. This is used to put data into areas on a spreadsheet.

f. Clear the cells in the column below the range. When this option is checked data in the cells below the
range will be cleared.

g. Add new columns before the range. New columns will be added on every request. To use this feature
all of the data requests should have the same cell target. This is useful to create a portfolio of values and
avoid editing several requests to remove a single request.
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Choose the Futures Contract Options then select Finish.
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In order to see the data, you must select Refresh Data from the MIM menu.

The MIM Excel Add-in runs the request and places the data in the selected column.
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This completes the browse data example. In the next lesson, you will see how to search using a MIM symbol.
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Search Symbols Example
Select Search Symbols from the Excel dialog.
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For this example, find the Natural Gas Futures using the Search Symbols feature. In the Search Text box,
type ng*, then select Start Search.
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Select NG Natural Gas Futures from the list, then select Next>>.
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Select NG from the left column, then select Volume from the right column.
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Select Next>> from the Excel dialog to continue.

Select the desired date information from the fields.
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Select the destination in the Excel Workbook. Click in the cell in the Excel Workbook where you want the
data to start. The entry will display in the Excel dialog. Unless merging data, it is a good idea to separate the
data columns in the Excel workbook with a blank column.
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Choose the Futures Contract Options then select Finish.
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Select Refresh Data from the MIM menu bar to display the data.
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The data displays with an empty column separating the data columns.

This completes the Search Symbols example.

Go to the next step in the lesson to see an example using the Search Descriptions option.
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Search Descriptions Example
The next feature in this lesson is the Search Descriptions example. Select Search Descriptions from the
MIM Data Selection dialog.
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For this example, type in heating oil in the search text box, then change the Limit Returned Answers
to 100. Select Start Search. Highlight HO – NYMEX: Heating Oil Futures (USC/GAL) and select
Next>>.
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Select HO - NYMEX: Heating Oil Futures (USC/GAL) from the left-hand column. Select Volume from
the right-hand column then select Next>> from the MIM Data Selection dialog to continue.
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Select the date and time ranges, then select Next>> from the MIM Data Selection dialog.
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Select the cell where the data will display in the Excel Workbook, keeping a blank column between the data
that has already been generated and the new data.
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Choose the Futures Contract Options then select Finish.
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Select Refresh Data from the MIM menu to generate the data. The data displays with a blank column
separating the data.

This completes the Search Descriptions example. Continue on to see a recently used data item example.
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Recently Used Data Item Example
You can reuse a data request by selecting an entry in the Recently Used Data Item field. Just select one of
the entries, then select the Next>> button. Change the date entries and corresponding column information
as needed.

This completes the Recently Used Data Item example. Go to the next step in the lesson to see how to
merge data.
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Merge Example
The examples so far have not used the merge function. Data has been separated in the worksheet with a
blank column between the data. When the Merge Data and Time box is checked, data can be merged so
that one date displays corresponding to multiple data requests.
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The example below shows the CL – NYMEX: Light, Sweet Crude Oil Futures Volume for a one-year
period.

Now let’s merge the HO – NYMEX: Heating Oil Futures Volume also at a one-year period with the CL
Volume.
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When merging data, the new data will display adjacent to the last data column. In this case, the program
automatically selects column B, row 1. The new HO Volume data will display in column C, row 1 adjacent to
the CL Volume data.
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The example below shows the result of the merge.

Merge Example - Dates and Data Retrieval Options Must Match
Dates and data retrieval options must match when doing a merge. If the CL Volume has the date set to one
year and the HO Volume has the date set to one month then the merge will not work properly.
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Let’s see what happens when the dates don't match. The CL Volume column becomes a date field. The dates
and data retrieval options must match when doing a merge.

Once an Excel column is filled with date information that column will always display data as
dates. You must reformat the column to contain number fields in order for data requests to
display correctly.

Merge Example - Restoring Date Fields to Number Fields
To reformat column B to contain numbers instead of dates:

1. Select column B.
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2. From the Excel menu bar, select Format>Cells.

3. From the Category list choose: Number and from the Decimal Place list choose: 0.
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4. Select OK.
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The following graphic shows the date field converted back to a number field.
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CHAPTER 4

Edit

This allows the user to modify data requests that have been previously setup with MIM>Add Data. There
will be a list of items, assuming requests have been setup previously.

We will continue with the merge example. We just finished showing how to change the date field to a number
field. Now, we will edit the data so that the data is not merged but displays in a new target cell. (We are not
merging the data as the date fields do not match.)

Do the following to change the HO Volume data request so that the data is not merged.

1. Select Edit from the MIM menu.

2. Select HO Volume Sheet1!$B$1 from the Edit display list, then select the Edit button.
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From the Recently used Data Item list, select HO Volume and select Next>>.

Do the following to change the destination on the Excel spreadsheet for the HO Volume data:

3. Select the Next>> button until you get to the destination dialog.
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4. Uncheck the Merge Data and Time columns into a single column for adjacent data requests box.
Select cell C:1. The CL Volume is in columns A and B. The data for HO Volume will be in columns C
and D.
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5. After editing the HO Volume data, close the  Edit  dialog by selecting the Close button.

6. From the MIM menu, run Refresh Data. The data displays showing the CL Volume for one year and the
HO Volume for one month.

This concludes the Edit Data lesson.
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Working Example

Problem
It might be interesting to access the daily closing price for the natural gas contract for the last 200 values
available in the database. Using the Excel Add-in, let's Add Data for the close of NG for the last 200 days of
data.

Step by Step Solution
1. Open the Excel program. From the menu bar, select MIM>Add Data.

2. The next step is to select Search Symbols and locate the NG symbol.
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3. Enter ng* and select Start Search.
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4. Select NG from the list and select Next>>.
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5. Select NG from the left-hand column and Close from the right-hand column. Select Next>>.
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6. From the Get data from field, select the last 200 days. Select Next>>.
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7. The data is setup to display in the first cell of the spreadsheet. Select Next>>.
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8. Choose the Futures Contract Options. For this example, keep the defaults. Select Finish.
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9. From the MIM menu, select Refresh Data.
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10. The query runs and displays the data, i.e., the closing amounts for the NG future for the last 200 days.

This concludes the Working Example. Next, see how to use the MIM Queries/Run All Queries option.
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CHAPTER 5

MIM Queries/Run All Queries

These two functions allow the user to create and edit queries as well as run all the queries at one time.

Problem
The following problem will demonstrate how to use the MIM Query and Run All Queries option. In this
lesson, you will determine the gas spread between Chicago gas prices and Henry Hub (Louisiana) during the
winter months.
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Step-by-Step Solution
1. The first step in creating an advanced MIM query is to select MIM Queries from the MIM menu.

Query List Dialog
2. The next step in creating an advanced MIM query is to enter the information in the Query List dialog

box.

Type an entry in the Name field, then select Create. A description of the user and the queries can be
entered in the Description field. This description field becomes active in the next display after selecting
Create.
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After you create a query, you can return to this dialog box to run the query, later edit the query, create a
new query, delete the query or copy the query. Close will return you to the Excel worksheet.

Create Query Dialog
3. Enter the following query in the Create Query dialog box. Enter a Description then select OK.

A query can be developed and tested using the XMIM, then copy/pasted into this query
box.
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4. Select Close to close the Query List dialog box.

The following options can be set:

● Execution Units  - Pick the time frame units for the data (seconds, minutes, days, years, etc.).

● Current Tick Data  - If you have a real-time feed connected to the MIM server, check Current Tick
Data. (Consult your LIM System Administrator as this is not common.)

● Summary Stats  - In order for the MIM to generate summary statistics to go along with the data request,
check Summary Statistics. The statistics included are: Sum, Average, Average Positive, Average Negative,
Percent Positive, Percent Negative, Highest, Lowest, Standard Deviation, Z stat, and Variance.

● Clear Worksheet  - Clears the worksheet of any data before displaying the new query data. Note: If several
queries have been created, they will execute in alphabetical order and only the first one should have this
box checked. If the second, third, etc. query had Clear Worksheet checked, then the first query’s results
will be erased.

● Print Data Headers  - This option prints the assigned label names at the top of the columns in the
spreadsheet.

● Decimal Places  - Set the decimal place. The default is set to 5.
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● Target Cell  - Select the bar next to the destination cell:

The Create Query dialog closes and the Excel Worksheet opens. Select the desired cell to store the data
and then select the  button to return to the Create Query dialog.

Run All Queries
5. After creating queries, you can run them all at once by selecting the Run All Queries from the MIM

menu. After running a query, you can go back and edit the query or make a new query by selecting MIM
Queries from the MIM menu.
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An example of a portion of the resulting data for the query:

6. Clear the spreadsheet before continuing to the next example.
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CHAPTER 6

Get Records Function

The Get Records function is a fast method for fetching and analyzing data. This function takes the data that
is entered on the spreadsheet and populates the relation, column, date and time fields in the program.

Problem
Look at the Close, Open and Volume for NG, CL and HU for January 1, 2001 through February 1, 2001
between 10:00 am and 1:00 pm.
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Step-by-Step Solution
Enter relation data on any row of the spreadsheet. On the next row enter the column data. The following row
is reserved for the date fields in the first two columns and the time fields in the next two columns. The data in
the spreadsheet must be aligned in a contiguous manner so that all the data will be selected.

After entering the data in the spreadsheet you will select the cell containing the first relation name entry and
then you will select Get Records from the menu bar. All the data entered will automatically populate the
corresponding fields in the display box.

The following outlines this process in detail:

1. Enter the symbol names in the first row. Type NG in cell A:1, CL in cell B:1 and HU in cell C:1.

2. Next, enter the column data. Type Close in cell A:2, Open in cell B:2 and Volume in cell C:2.

3. On the next row, enter the date and time information. For Date From enter 1/1/2001 in cell A:3, for
Date To enter 2/1/2001 in cell B:3. On the same row enter the time fields. For Time From enter 10:00
am in cell C:3, for Time To enter 1:00 pm in cell D:3.

4. Select cell A:1 then select Get Records from the MIM menu.
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5. The fields will automatically populate the Fetch Historical Data from XMIM Server box. For Source
Ranges, cells A:1 to C:1 will display for the Relation Name cells. Cells A:2 to C:2 will display for the
Column Name cells.

6. For Destination Range, the data will populate in cells A:4 to I:4. Keep the -1 value in the Num rows
box if you want all the data rows to display. If you want only a certain number of rows to display type in a
specific number.

7. For the Reshaping field, select a Units option: Years, Quarters, Months, Weeks, Days, Hours or Minutes.
Since we are dealing with intra-day data, select Hours. Enter a value for Number of Units. All the values
will display with the default setting of 1.

8. In the Options field, set the decimal place. The default is 5.

9. The Date Range field will automatically populate with a date range from cell A:3. The date range fields
are optional. If a Date Range is not entered, all the dates for the symbol will be queried. The Date
Range must be entered in the following format: mm/dd/yyyy.

10. Since we entered time ranges in the spreadsheet in cells C:3 and D:3 these cells automatically populate
the time range fields in the display box. The Time Range field is optional. The Time Range is in the
format: hh:mm am/pm. Keep in mind that when entering a time range, Hours or Minutes must be
selected in the Units box in the Reshaping section.
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11. Select a Fill Option from the pull-down menu. A default NaN is filled if there is no data point available
for a given date. Use the pull-down menu to have the data filled in other ways (e.g. Filled Forward or
Backward, Linear, Geometric or Logarithmic interpolated values). For this example, select Skip all-NaN
records. All the NaN values will not display.

12. Select OK to run the query.

The following shows the results for the Get Records query. Columns labeled 1, 2, 3 are the Close, Open and
Volume for NG. The next three columns are the Close, Open and Volume for CL. The last three columns
are the Close, Open and Volume for HU.

This completes the Get Records lesson. Next, see how to use the Show When function.
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CHAPTER 7

Show When Function

Create Show When queries quickly by pulling data entered on a spreadsheet. Enter the Show statements in a
column on the spreadsheet. Enter the When statements in the next column.

The program will automatically fill in the Show-When Query Server dialog box with your fields. The
program will skip a row and put the answers at the beginning of the next row. (For the following example
Row 4.)

Problem
For this example, let’s find the Close of Natural Gas Futures (symbol is NG) and Crude Oil, Light Sweet
Futures (symbol is CL) when the date is after June 1, 1999.
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Step-by-Step Solution
1. Type the following information into the Excel spreadsheet: The Show statements are: Close of NG,

Close of CL. The When statements are: Date is after June 1, 1999 and NG is defined. When you are
finished entering the data make sure you click back on the first entry. This cell designates the starting
point for the data entries.

2. Select Show When from the MIM menu.
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The Execute Show-When Query Server dialog box displays. The program automatically fills in the
source and destination ranges based on where the data is entered on the spreadsheet.

If you want to change which data is selected, you can put your cursor in the Attr cells
text box, go to the Excel spreadsheet and then select the desired cells in the spreadsheet.
Another method for selecting data is to select the bar next to the destination cell

 then select the data from the spreadsheet. Using the  button returns you
to the Execute Show-When Query Server dialog box.

3. For Destination Ranges the program skips a row and then displays the data on the next row. The Num
rows box has a default value of -1. When -1 is entered, all the data for the query will display. If you would
like a certain number of rows of data to display enter a specific number.

4. For the Exec Units category, enter a value in the Num of Units box. The current default is 1. This field
controls how often the data will display. For example, if this value was set to 5, every fifth day would
display on the spreadsheet.

5. For the Units box, select a type of unit such as Years, Quarters, Months, Weeks, Days, Hours or Minutes.
For our example select Days.

6. For the Options category, select a decimal place setting in the Decimal Place box.

7. Select OK to close this dialog box.
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8. The Show When query will run and display in the designated target cells as shown below.

9. Clear the screen before proceeding to the next example.
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CHAPTER 8

Forward Curve

Use the Forward Curve function to create a study where multiple contracts can be charted over several years
easily on a single chart. The following will show how to set the options for a forward curve.

1. From the MIM menu, select Forward Curve.
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The Forward Rate Curve dialog box displays.

2. Enter a symbol in the Symbol box. For our example, enter NG.

3. The Last Data Day field uses the most recent date available unless a specific date is entered. For our
example, enter 05/13/2002.

4. In the Forward Curve Labels category, you can set Dates or Labels to display on the chart. For our
example keep the default.

5. In the Destination Ranges category, select a Target Cell  in the spreadsheet where you would like the
data to begin displaying.

6. In the Options category, you can change the decimal place setting using the pull-down in the Decimal
Places box. Clear Worksheet will clear the contents of the worksheet before displaying the new data.
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Make Forward Chart will create the Forward Rate Curve chart. For our example, keep the default
settings. Select OK to display the data and chart in the spreadsheet.
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The following shows the results of the Forward Curve chart settings for the NG (Natural Gas) futures.
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CHAPTER 9

Load Data
Data can be loaded into the MIM via the MIM Excel Add-in. It is first necessary to install the data load
servlets to setup the Web server. For instructions on setting up the Web server, please see the “Data Loader:
Server Setup Instructions” chapter in the MIM Data and Development Guide.

How to Use the Data Loader
The following gives detailed instructions on how to load data using the Load Data selection on the MIM
menu.

Enter Data on the Spreadsheet
The first step in using the data loader feature is to enter the data on the Excel spreadsheet in the following
format:

● First cell contains the relation name.

The relation name can either be a new name, or one that is currently in the database.

● The next cell, moving horizontally across the spreadsheet, contains the column name.

The column name must be a name that is already assigned in the MIM database.
To see what column names can be used, see the column catalog located at: http://
customers.lim.com/menu/column_catalog.htm.

● The third cell should contain the date in any format that Excel will accept. If you add a time to this
column, the data loader will assume the data is of an intra-day format (i.e., minutely).

Data at less than minute frequency (tick) is not supported. The time entry is optional and
the format should be HH.MM.

http://customers.lim.com/pdfdocs/data_dev_guide.pdf#Loading_Data_via_the_MIM_Excel_Add-in_Data_Loader_Server_Setup_Instructions
http://customers.lim.com/pdfdocs/data_dev_guide.pdf#Loading_Data_via_the_MIM_Excel_Add-in_Data_Loader_Server_Setup_Instructions
http://customers.lim.com/menu/column_catalog.htm
http://customers.lim.com/menu/column_catalog.htm
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The data will usually be loaded by default into TopRelation:User but custom locations may be configured
for some systems. For more information see the “Data Loader: Server Setup Instructions” chapter in the
MIM Data and Development Guide.

● The fourth cell contains the data. The data can be either an integer or a float, depending on the column
assigned. The data will be converted to the correct format by the system if necessary.

● The fifth cell contains the description for the symbol. If more than one description is entered for a symbol
only the first entry will be used, any other entries will be ignored.

Column F must be left blank otherwise you will get an error message. You may enter text
in Column G and beyond, but in order for the data loader to work you must have a blank
column after the description column (fifth column).

● In the last blank row type END_OF_DATA exactly as shown in the first column. This marker designates to
stop loading data at this point.

The following scenarios may apply:

● The relation name is one that is already in the system.
● The relation name is a new name.
● The column name does not exist.
● The updates package is running and the data is waiting in the queue to load.

Each of these scenarios will be covered in further detail.

http://customers.lim.com/pdfdocs/data_dev_guide.pdf#Loading_Data_via_the_MIM_Excel_Add-in_Data_Loader_Server_Setup_Instructions
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Load Data from the MIM Menu
The following shows the steps for running the data loader from the MIM menu.

1. After the data is entered in the spreadsheet, click off of the cell containing the last entry and then click
back anywhere on the spreadsheet.

2. From the MIM menu, select Load Data. Each of the items below shows a possible scenario when
loading data:

a. If the relation name is new, the dialog box will prompt the user to Submit the Data as 5 Day Series,
Submit the Data as 7 Day Series or Cancel.
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b. If the relation name is not new and no problems are found, the user is prompted to Submit the Data
or Cancel.

c. If a problem is encountered. For example: the following graphic shows the user loading the data with
the column set to Closex. If the column name does not exist, the message The following columns
are not supported will return.
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Fix the column name, then resubmit the data. Select Submit Data to load this data.

After the data is submitted, the data will be put into the queue for loading. If an updates package is
running, the data will remain in the queue until the package has finished loading. When the data has
loaded successfully, a confirmation window will display.
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CHAPTER 10
Get Options and the Options Facility

Introducing the Options Facility
The Options Facility refers to a portion of the MIM Data Warehouse that has been organized to allow
specialized analysis of options data. There are several LIM applications developed for extracting data from the
Options Facility. This section specifically outlines how to use the Get Options feature in the MIM Excel Add-
in. For more information on extracting data using other tools, please see the Options Facility document.

Options Data Offerings
The data in the Options Facility can be divided into three distinct categories:

● Options contracts
● Standardized at-the-money forwards
● Underlying equities

LIM has over 6 years of US equity and index option history available including: a complete history of the
individual options contracts, standardized at-the-money forwards, and a full compliment of options related
information for the underlying equities.

The options contracts and standardized options are updated daily for pricing, premium, implied volatility, and
sensitivities. The underlying equities have options summary data including: option volume totals, open interest
totals, and implied volatility.

Tools for Extracting Options Data
There are two applications that have been developed to extract data from the Options Facility: the Get
Options  feature in the MIM Excel Add-in and a customized Options Command Line application.

The MIM API was enhanced to allow this integration of customized applications with options analysis. By
using C API calls to XmimGetRecordsOptions  our applications were developed to extract data from the
Options Facility.

Using these tools, one can filter the options data by put/call, strike price, expiration date, and perform special
handling for non-computable values. In addition, the options product suite extends the capability to unlimited
possibilities for an options trader to develop and monitor trading methodologies.

http://customers.lim.com/pdfdocs/options_facility.pdf
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  Important Note for Options Contracts

The standardized at-the-money forwards and underlying equities can be researched
using any of our suite of analysis tools: XMIM, MIMIC or the MIM Excel Add-
in. It is important to make the distinction that the options contracts are accessible
using the following tools: the MIM Excel Add-in and the Options Command Line
application. For more information on the Options Command Line application,
please see the Options Facility.

 

Columns for Options Data
The following list outlines the columns available for use with options data:

● Date (values always returned)
● Expiration Date (values always returned)
● Put/Call (values always returned)
● Strike Price (values always returned)
● BidPrice
● OfferPrice
● LastTradeDate
● Volume
● OpenInterest
● ImpVol
● OptionDelta
● OptionGamma
● OptionVega
● OptionTheta

Each equity, as the underlying issue, will have some additional columns of options related data:

● CallVol
● PutVol
● TotalVol
● ImpVol

Note that this column is the average of the 30 put and 30 call in the standardized options.

● CallOI
● PutOI
● TotalOI

http://customers.lim.com/pdfdocs/options_facility.pdf
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Get Options
Use the MIM Excel Add-in Get Options feature to access the special columns established for analyzing
options data. This function takes the data that is entered on the spreadsheet and automatically populates the
relation, column, date, expiration date, strike price and put/call fields in the program.

Working Example
Look at the option Gamma for IBM for dates ranging from 5/7/2002 to 6/12/2002 and expiration dates
ranging from 5/02 to 6/02 with strike prices ranging from 50 to 70.

Step by Step Solution

Overview

In order for the software to automatically pick up the entries from the spreadsheet and fill in the dialog box,
the user must fill out the spreadsheet in a specified order and click on the first relation cell entry before
choosing Get Options from the MIM menu. Selecting the first relation cell entry on the spreadsheet, tells the
program where the data entries begin on the spreadsheet. All the data entered will automatically populate the
corresponding fields in the display box.

The user may start entering data from any point on the spreadsheet but must follow the specified
order from that point on.

Enter relation data on any row of the spreadsheet. On the next row enter the column data. The following
row is reserved for the date fields in the first two columns, the expiration dates in the next two columns, the
strike price range in the next two columns and the put/call/both option in the last column cell. The data in
the spreadsheet must be aligned in a contiguous manner so that all the data will be selected. If this format is
not followed the data will not populate the next dialog box correctly.

The user has the option of entering data on any of the cells in the spreadsheet, not in a
contiguous manner. After Get Options is selected from the MIM menu the dialog box will
display. Instead of having the data automatically populate the fields in the display box, the user
can select the individual cells in the spreadsheet to fill in each field of the display box.

The following is an example of how to select information in a cell on a spreadsheet to populate a field in the
display box:

1. Select the bar next to the destination cell.  The dialog box will close and the Excel Worksheet
opens.
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2. Select the desired cell on the spreadsheet, then select the  icon to return to the dialog box. The dialog
will now contain the spreadsheet entry.

Spreadsheet Entries

The following outlines the process in detail. Follow along with this example to learn how to enter options
data in a spreadsheet and have the entries automatically populate the query dialog box.

An older version of the Options Facility allowed the user to enter as many relations as they
wanted, but because of the new formatting functionality in the latest version, the user can only
enter and view data for one relation at a time.

1. Enter the symbol names in the first row. Type IBM_Options in cell A:1.

2. Next, enter the column data. Type OptionGamma in cell A:2. If you wanted more than one column,
then you would enter the next column data in cell B:2, then C:3 etc.

3. On the next row, enter the dates, expiration dates, strike price ranges and the put/call options. Enter P
or p for Put and C or c for Call. If left blank the default is to display both Puts and Calls. The following
graphic details the entries:

In Excel, sometimes the cells pickup the formatting of a previous cell entry. The Strike
Price entries may get reformatted as Date entries. To fix this, right-click on the Strike
Price cells and select Format Cells, then change the formatting to General.

4. Select cell A:1 then select Get Options from the MIM menu.

  You must select the first relation cell entry to designate where the program
will start pulling the data from the spreadsheet.
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The following screen displays:

5. The fields will automatically populate the fields. For Source Ranges, cells A:1 will display for the
Relation Name cells. Cells A:2 will display for the Column Name cells.

6. For Destination Range, the data will populate in cell A:4.

7. For Put/Call, the default is for the Both box to be checked. Checking the Both box will list both Puts
and Calls. On our spreadsheet, we entered a “P” for Put so the Put box is automatically checked.

8. For Data Format, the default is for Unformatted to be checked. If you want to format the output so
that the data is listed in a column format check Formatted. For the following example keep the default
Unformatted option. At the end of the example we will show how the Formatted data will display.

9. For  Non-Computable Values, select this check box so that –99.99 non-computable values will not
display on the spreadsheet. For our example, check the Skip all Non-Computable Values check box. By
default, this box is not checked. Note: “non-computable value (-99.99)” means that the value is trading
outside its intrinsic value and therefore is not meaningful or applicable.
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10. The Date Range field will automatically populate with a date range from cell A:3 for the From box and
B:3 for the To box. The date range fields are optional. If a Date Range is not entered, all the dates for
the symbol will be queried. The Date Range must be entered in the following format: mm/dd/yyyy.

11. The Expiration Date Range field will automatically populate with a date range from cell C:3 for the
From box and D:3 for the To box. The expiration date range fields are optional. If an Expiration Date
Range is not entered, all the dates for the symbol will be queried. The Expiration Date Range may be
entered as mm/yy or mm/dd/yyyy. If mm/yy is entered, the cell will display as mm/01/yyyy.

12. The Strike Price Range field will automatically populate with a date range from cell E:3 for the From
box and F:3 for the To box. The Strike Price Range fields are optional.

13. Select a Fill Option from the pull-down menu. A default NaN is filled if there is no data point available
for a given date. Use the pull-down menu to have the data filled in other ways (e.g. Filled Forward or
Backward, Linear, Geometric or Logarithmic interpolated values). If Skip all-NaN records is selected
then all the NaN values will not display.

14. Select OK to continue.

Results

The following shows a portion of the results of the query with the Unformatted option selected:

For the next example, we've added a few more greeks to the list: OptionDelta, OptionTheta and
OptionVega. We've started the entries on cell B:1 to show that you can start your entries anywhere on the
spreadsheet. This time we're just entering the start date 5/2/2002. All the data will display back to 5/2/2002
and both Puts and Calls will be listed.
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Now put your cursor back on the IBM_Options cell, cell B:1 and select  MIM>Get Options. Remember
that we can enter data starting at any point on the spreadsheet and we have to select the starting cell before
we choose Get Options. We are going to show how the data displays when the Formatted option is selected.

Note that under Data Format, the Formatted option is checked.

The following graphic shows a portion of the results.

The Quote date, Expiration date and Underlying prices are listed as well as both Puts and Calls and each
Option type.
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CHAPTER 11

Using MIMICExcel

Synopsis

Objectives
1. Launching MIMICExcel.
2. Embedding a query.
3. Using the MIMICExcel Advanced Refresh Mode option.
4. Using the Query Manager in MIMICExcel.
5. Exporting an embedded query.

Market Brief

MIMICExcel is an applet or application that you use from within Microsoft Excel®. When you open Excel
and then run MIMICExcel, you have all the functionality of MIMIC from within the Excel environment.
With MIMICExcel, you can seamlessly incorporate table data from your queries into your Excel spreadsheet.

To obtain this functionality, make sure you have MIMIC version 3.0 or higher installed on your system. For
details on installing the MIMIC application, see the “MIMIC Installation and Purchase Options” chapter in
the Client Application Installation Guide.

You must have Java version 1.4 or higher. To obtain a free Java download, go to: http://
www.java.com.

http://customers.lim.com/pdfdocs/install_limapps.pdf#MIMIC_Installation_and_Purchase_Options
http://www.java.com
http://www.java.com
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After installing MIMIC 3.0 or higher, start Microsoft Excel. You will notice the addition of the MIMIC menu
in the Excel menu bar, and the addition of the MIMICExcel Add-in toolbar, which contains two buttons:

● The Enter MIMIC  button. (MIMIC>Enter MIMIC from the Excel menu bar.)

● The Refresh MIMIC Queries  button. (MIMIC>Refresh MIMIC Queries from the Excel menu
bar.)

To open MIMICExcel, select the Enter MIMIC  button. The first time you enter MIMICExcel, an
authentication message displays. Select Yes if you want the authentication window to come up each time
you select the Enter MIMIC  button. Select Always to always authenticate MIMICExcel (recommended
choice – you will not see this dialog again unless the MIMIC software is upgraded).

The MIMIC Java Certificate expired as of February 21, 2005. If you selected Always to trust the
certificate, you will not see the expired certificate message and you will not be required to take
any action. To upgrade your certificate, so that you do not receive an expired certificate message,
please go to the LIM “Downloads” Web page and install the latest MIMIC application.

Note the following information regarding expired certificates:

● If the certificate displays with an expired message, MIMICExcel can still be started by selecting Yes or
Always.

● Users who have selected Always to trust the certificate will not see the expired certificate message and will
not be required to take any action.

● MIMIC stand-alone is not affected by the expired certificate.

http://customers.lim.com/download/index.html
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Once authenticated, the MIMICExcel window displays:

The MIMICExcel interface is the exact same as the MIMIC interface with the addition of the MIMICExcel
toolbar at the top of the window. The MIMICExcel toolbar contains three buttons: 1) The Back to Excel

 button to close MIMICExcel and return to the Excel spreadsheet (If you close MIMICExcel instead of
using the Back to Excel  button, it will take longer to open MIMICExcel the next time.), 2) The Query
Manager  button to manage previously saved embedded queries in MIMICExcel and 3) The Embed
Query  button to save or embed an active query within MIMICExcel.
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Problem
This problem will show how to create a query within MIMICExcel, save or embed the query, and display the
results in an Excel spreadsheet. For this exercise, you can show the Close of NG (Natural Gas Futures) and
CL (Crude Oil, Light Sweet Futures) from June 1 to September 30 for the last two years. You want the results
of this embedded query to appear in the Excel spreadsheet in cell A:1 (default location).

In MIMICExcel, queries that you save are referred to as embedded queries. This means that your
queries are available within MIMICExcel and the query results can be refreshed or updated, with
the results tabled to your Excel spreadsheet.
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Step-by-Step Solution

Creating an Embedded Query in MIMICExcel

If you are not already in MIMICExcel, select the Enter MIMIC  button in Excel (or select
MIMIC>Enter MIMIC from the Excel menu bar).

1. Enter the symbol NG, then press Enter. Verify that Close is selected for the Column. Change the Units
to BBL, so you will be comparing the same units of measure as the Crude Oil Light Sweet Futures (CL).

2. Add a new row by selecting the Add Row  button. Then, enter the symbol CL and press Enter. Verify
that Close is selected for the Column.

3. For the start date, uncheck Relative and enter the date 06/01/2001.

4. For the end date, uncheck Today and enter the date 09/30/2003.

5. In the Worksheet Options pane, uncheck Skip all NaN, and then from the Missing Data NaNs pull-
down, select Fill Blank. This choice will fill all missing data with a blank. This option is very useful when
working in Excel with formulas where the results are calculated values from the query results.

6. Select the Table  button. The first time you select the Table button, MIMICExcel displays the Embed
Query window, and asks you to save and embed your query:

Enter a name for your query in the Name field and a description for the query in the Description field.
Leave the Location field for now, but note that you can change the location by selecting the Browse
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button to the right of this field. Next, select OK. The Embed Query and MIMICExcel windows close,
and the results of the query appear in your Excel spreadsheet:

In MIMIC, table data is displayed in the Table window. In MIMICExcel, table data is
displayed in your Excel spreadsheet.

You can open MIMICExcel again to view your query by selecting the Enter MIMIC  button. You
can also run the query again to update the data in your spreadsheet by selecting the Refresh MIMIC
Queries  button or by selecting MIMIC>Refresh MIMIC Queries from the Excel menu bar:

7. Now, save your Excel spreadsheet. From the Excel menu bar, select File>Save. Create a name for your
spreadsheet and save it to your Desktop. Your spreadsheet will be saved with an Excel .xls file extension.
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If you do not save your Excel spreadsheet, you will lose the data in your spreadsheet as
well as any queries you have created in MIMICExcel.

Narrowing the Date Range using Advanced Refresh
Next, you will narrow the date range using the Advanced Refresh Mode option. This option saves time
because you do not have to go back into the query and modify the dates for each item listed.

1. Highlight the contents of the spreadsheet, right-click and select Clear Contents.

2. Next, put your cursor in the cell where you want the data to display. For this example, select cell A:1.

3. To narrow the date range, turn on the Advanced Refresh Mode option by selecting
MIMIC>Advanced Refresh Mode from the Excel menu bar. Then, select the Refresh MIMIC
Queries  button or select MIMIC>Refresh MIMIC Queries from the menu bar. Enter a start and
end date of 10/10/2001 and 10/22/2001. Select Active Worksheet Only, then select OK to continue.
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The following shows the results of the date range:

4. Save your Excel spreadsheet.

Make sure that you save your Excel spreadsheet before exiting Excel. The next time you
open the Excel spreadsheet you will be able to refresh the queries, and when you open
MIMICExcel you will be able to see any queries that were created.

Using the Query Manager in MIMICExcel
In MIMICExcel, you can save and embed more than one query. Embedded queries are stored in the Query
Manager. You can open and edit an embedded query, or copy, rename or delete a query.

You already saved a query earlier in this chapter by saving your Excel spreadsheet, so now you can access that
query.

1. Open your Excel spreadsheet.

2. Within Excel, select the Enter MIMIC  button. MIMICExcel opens.
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3. From the MIMICExcel toolbar, select the Query Manager  button. The Query Manager window
displays with your previously saved query:

4. Select Edit, and then Cancel on the next pop-up window. MIMICExcel displays the details of the query.

You can only access an embedded query by using the Query Manager. You cannot open a
query from the menu bar or from the MIMIC toolbar.

If you make changes to a query, you can save it with a new name, thus creating a new
query, or save it with the same query name. If you save it with the same query name,
MIMICExcel will ask you to overwrite the query. Each time you create a new embedded
query, you must save the Excel spreadsheet.
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Exporting an Embedded Query
You can also export an embedded query as an LLC worksheet that can be used in stand-alone MIMIC.

1. From the menu bar within MIMICExcel, select File>Save or File>Save As, or select the Save  button
from the toolbar. The Save window appears:

2. Enter a name for the query and select Save.

You must save each embedded query as its own LLC worksheet.
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Problem Solvers
1. Practice bringing in an existing MIMIC .llc file into Excel.

2. In MIMICExcel, create a query and save the results starting in cell D:8.
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CHAPTER 12

XmimGetData

With XmimGetData you can pass the results of a MIM query into the cell of a worksheet. There are four
input parameters for XmimGetData:

relation, column, start date, end date (optional)

The following is an example of how to enter the string:

=XmimGetData(“HO”, “Close”, “6/1/2004”, “6/30/2004”)

where:

“HO” is the relation name
“Close” is the column name
“6/1/2004” is the start date
“6/30/2004” is the end date

Select MIM>Refresh Data from the Excel menu bar to return a value back into the selected cell on the
worksheet.

The following graphic shows the XmimGetData string entry and how the data result is returned back into the
selected cell. The MIM query equivalent to this entry would be Show Close of HO When date is 6/1/2004
to 6/30/2004.
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The user can also just pass the start date and no end date. The graphic below shows an example of only
entering a starting date:

Each argument can be passed to XmimGetData directly or indirectly. In the example above the argument is
passed directly as the symbol, column and date information is entered directly in the string field.

To pass an argument indirectly, a user can specify the relation, column, start and end dates on another
location in the spreadsheet. In the example below, the user is indirectly referencing the argument strings in
cells D1, E1, D2 and E2.
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An argument may be passed both directly and indirectly by entering some of the information in the string
field and referencing some of the information from the worksheet cells. In the example below, the relation
name CL and the column name Close is entered in the string field. The start date 3/1/2004 is referenced in
cell D2 and the end date 3/15/2004 is referenced in cell E2.
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CHAPTER 13

Option & Help Settings

MIM>Options
In the MIM menu, there are two choices next to the Options heading: Config MIM Connection and
Preferences.

Options>Configure MIM Connection
The MIM Server pane shows the MIM server and port that you are pointing to. These parameters are filled
in during the installation process. You can change these setting to point to a different host or port number.
For Host Name, specify the machine by host or IP address. A Port number is required.
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The Web Server pane allows you to change the Web host and port for loading data.

Options>Preferences
In the Preferences dialog box the user can set the precision of the decimal place, control when the data is
refreshed, choose a date format and choose whether to have a time stamp.
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The following describes each field:

● Precision - Use this field to set the decimal place settings for the data.

● Refresh - When this box is checked data will automatically refresh and populate the Excel spreadsheet. If
this box is not checked, the user must select MIM>Refresh Data from the menu bar to run the queries
and populate data in the spreadsheet.

● Date Format - Choose the date format, either mm/dd/yyyy or dd/mm/yyyy.

● Time Stamp - When Include Time stamp when available box is selected, the time will display in the
format: hh:mm:ss am/pm. The time will display in the same column as the date unless the Time stamp in
separate column box is checked.
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MIM>Help
In the MIM menu, there are two choices next to the Help heading: About MIM Excel AddIn and Goto
MIM Excel Website

Help>About MIM Excel Add-In
This returns the MIM Add-in version number, date of release and support options.

Help>Goto MIM Excel Website
The MIM Excel Web site will open in your browser. See the on-line tour and movie for more information on
the features in the MIM Excel Add-in.
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